[notmuch] Snippet to jump to message in Gnus from notmuch-show buffer

Carl Worth cworth at cworth.org
Wed Dec 2 12:51:41 PST 2009

On Fri, 27 Nov 2009 23:10:30 +0100, Tassilo Horn <tassilo at member.fsf.org> wrote:
> Well, if you only want to have a look at a maildir or mbox, and don't
> want to make the group permanent and let gnus fetch mail, then this
> should do the trick.
>   M-x gnus RET ;; brings you into the *Group* buffer, and then
> | `G m'
> |      Make a new group (`gnus-group-make-group').  Gnus will prompt you

For viewing an mbox, I successfully used "C-u G f" that you mentioned
earlier. So I've at least now seen gnus in action, thanks!

What I'd really to view is a maildir though, but I haven't gotten "G m"
to work with that yet. It prompts me for a "group name", (which I assume
is just an arbitrary string), then a "from method" which offers tab
completion for things that look promising (such as "nnmh" and
"nnmaildir") but I can't get anything to work past that. I never see
anything prompting for an actual directory, and it either ends up
creating an empty directory, (such as ${HOME}/Mail/<groupname>), or
complaining "Wrong type argument: stringp, nil".

I even guessthat that maybe it wants "nnmaildir:/path/to/maildir" or
maybe "nnmaildir+/path/to/maildir" but the prompt won't accept either of
these (just says "[No match]").

And now I've got an entry in the *Group* buffer for each of my attempts,
which variously complain ("Couldn't open server" for nnmaildir:foo,
"Group nnmh:bar contains no messages", and "Couldn't activate group
test: No such group"---I can't remember how I created that one).

Where are all of these groups stored now? (I couldn't find anything
matching ~/.gnus* nor any changes to my .emacs file.) Yet I still see
these broken groups even with "emacs -q -f gnus". And how do I delete

Update: It looks like I've got stuff in ~/.newsrc, ~/.newsrc-dribble,
and ~/.newsrc.eld from my various thrashing here. Still not clear how to
delete things---.newsrc.eld says I shouldn't delete it but should touch
~/.newsrc instead, but that doesn't seem to have any effect. I went
ahead and deleted ~/.newsrc* and most of this stuff does seem to be
nicely cleaned up. All that's left is that I now get a warning on
starting gnus of "Gnus auto-save file exits.  Do you want to read it? (y
or n)". If I do read it, then I get some of the junk groups back. I
can't figure out where this auto-save file exists, (it's even hiding
From my attempt with strace).

> This does only work if the group already exists inside Gnus.  So you
> might consider setting it up properly, although it's a bit first-time
> effort.

I'll keep trying...

> (setq gnus-select-method '(nnnil))

Thanks for this! This allows me to start gnus without the annoying "go
offline?" errors. And what's more, when I put this in my .emacs, delete
all of ~/.newsrc*, *and* answer "no" to the prompt to read the gnus
auto-save file---if I do all of that then I *finally* get the
"gnus-help" group that I'm certain I was supposed to get the first time
I ran "M-x gnus".

So maybe I'll be able to find something in there.

Hrm... still seeing the same inscrutable stuff that I find every time I
try to read gnus documentation. The "I want to read my mail!" post
describes "nnml" as "a one-file-one-mail backend" but then the closest
it gets to how to use it is:

	So if you want to go with nnmbox, you can simply say:

	(setq gnus-secondary-select-methods '((nnmbox "")))

	(The same for the other methods, kind of.)

And I'm lost. Besides the "kind of", which just makes me uneasy, how
does it make sense to configure an mbox backend with just an empty
string? Surely something needs to be told where to find an actual mbox

Or is this just selecting a backend for how GNUS should store mail that
it fetches?

Is there any hope for someone like me that doesn't want GNUS involved in
fetching mail, but just wants to use GNUS to read mail files that I have
in a big hierarchy of directories? I keep feeling there must be a simple
document somewhere that explains how to do that---but I just can't find

-Carl (hoping that notmuch will eventually be more approachable than gnus)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://notmuchmail.org/pipermail/notmuch/attachments/20091202/df691b6a/attachment.pgp>

More information about the notmuch mailing list