Address Completion No Longer Working

David Bremner david at
Mon Mar 12 03:47:42 PDT 2018

david wen riccardi-zhu <dwrz at> writes:

> Address completion worked out of the box for me with notmuch and 
> Emacs. Recently, it's stopped working. I've tried setting 
> notmuch-address-command to internal, as well as toggling 
> notmuch-address-toggle-internal-completion, but neither has been 
> able to return the functionality.

"stopped working" usually suggests some configuration change to me. It
would be helpful to know what precisely changed.

As far as debugging, I had two ideas to try.

- try running (notmuch-address-matching "dwrz") in *scratch* (or IELM,
  or M-:) ; this will eliminate company-mode as a suspect, and
  potentially give you a traceback if something is going wrong.

- have a look at the variable notmuch-address-save-filename. Potentially
  set it (back) to nil to disable persistent caching. If that fixes it,
  have a look at the corresponding file, see if something corrupted it.

> I use:
> Arch Linux X86-64, Kernel 4.15.7-1-ARCH
> fish shell

fish breaks lots of assumptions for shells, but I guess you didn't just switch.

> notmuch 0.26

some subtle things changed with respect to starting external processes
in notmuch 0.26; if your recent configuration change was upgrading
notmuch, that might be worth further investigation.

More information about the notmuch mailing list