reply to messages with message/rfc822 parts

David Bremner david at
Sun Mar 12 09:26:49 PDT 2017

Mark Walters <markwalters1009 at> writes:

> Hello
> I was trying to reply to a message I had forwarded to someone (to update
> the information sent in the first message) and came across some strange
> behaviour.
> The initial forward was done using notmuch-emacs: this took the message
> and sent it as a message/rfc822 mimetype complete message. Since I had
> added some text at the top this meant the message as a whole was
> multipart/mixed with my text/plain at the top and the message/rfc822
> below.
> Then I tried to reply to this message and the text/plain part was
> included in the reply but the message/rfc822 part was not. In this case
> the message/rfc822 just had headers and a text/plain subpart so I would
> have expected it to be included.
> I imagine we actually want to recurse into the message/rfc822 part
> including relevant subparts. I tried tweaking notmuch-mua.el to do this
> but, so far, I have failed. (I will have another look)

As far as I know this problem is now fixed.


More information about the notmuch mailing list