[PATCH 06/11] lib: Internal support for querying and creating ghost messages

David Bremner david at tethera.net
Sun Oct 5 01:30:30 PDT 2014


Austin Clements <aclements at csail.mit.edu> writes:

> +	    message->flags &= ~(1 << NOTMUCH_MESSAGE_FLAG_GHOST);

What do you think about using bit set / clear / read macros?  I don't
insist, but I wonder if it would make this part more readable.

> +	else if (*i == "Tghost")
> +	    message->flags |= (1 << NOTMUCH_MESSAGE_FLAG_GHOST);
> +	else

It makes me faintly unhappy to have the prefix hardcoded here.
Not sure if there is a sensible solution.


More information about the notmuch mailing list