[PATCH v5 0/9] notmuch search date:since..until query support
Jani Nikula
jani at nikula.org
Sun Oct 21 14:22:23 PDT 2012
Hi all, v5 of id:"cover.1350164594.git.jani at nikula.org", with the
following changes in patch 2 per Ethan's review
id:"87hapw9x99.fsf at betacantrips.com":
- remove useless intermediate function handle_postponed_number
- rename stringcmp to match_keyword
BR,
Jani.
Jani Nikula (9):
build: drop the -Wswitch-enum warning
parse-time-string: add a date/time parser to notmuch
test: add new test tool parse-time for date/time parser
test: add smoke tests for the date/time parser module
build: build parse-time-string as part of the notmuch lib and static
cli
lib: add date range query support
test: add tests for date:since..until range queries
man: document the date:since..until range queries
NEWS: date range search support
Makefile | 2 +-
Makefile.local | 2 +-
NEWS | 14 +
configure | 2 +-
lib/Makefile.local | 3 +-
lib/database-private.h | 1 +
lib/database.cc | 5 +
lib/parse-time-vrp.cc | 40 +
lib/parse-time-vrp.h | 19 +
man/man7/notmuch-search-terms.7 | 147 +++-
parse-time-string/Makefile | 5 +
parse-time-string/Makefile.local | 12 +
parse-time-string/README | 9 +
parse-time-string/parse-time-string.c | 1477 +++++++++++++++++++++++++++++++++
parse-time-string/parse-time-string.h | 102 +++
test/Makefile.local | 7 +-
test/basic | 2 +-
test/notmuch-test | 2 +
test/parse-time-string | 71 ++
test/parse-time.c | 281 +++++++
test/search-date | 21 +
21 files changed, 2206 insertions(+), 18 deletions(-)
create mode 100644 lib/parse-time-vrp.cc
create mode 100644 lib/parse-time-vrp.h
create mode 100644 parse-time-string/Makefile
create mode 100644 parse-time-string/Makefile.local
create mode 100644 parse-time-string/README
create mode 100644 parse-time-string/parse-time-string.c
create mode 100644 parse-time-string/parse-time-string.h
create mode 100755 test/parse-time-string
create mode 100644 test/parse-time.c
create mode 100755 test/search-date
--
1.7.10.4
More information about the notmuch
mailing list