[PATCH v4 0/6] Move --no-exclude to --exclude=(true|false|flag)
Mark Walters
markwalters1009 at gmail.com
Sat Apr 7 09:10:02 PDT 2012
This is version 4 of the exclude= patch set. Version 3 was at [1].
The only changes relative to version 3 are in the tests. As suggested
by jrollins [2] I have added some systematic count and show tests and
moved all the exclude tests to the file test/excludes.
Best wishes
Mark
[1] id:"1333716551-29153-1-git-send-email-markwalters1009 at gmail.com"
[2] id:"877gxs7ryv.fsf at servo.finestructure.net"
Mark Walters (6):
lib: change default for notmuch_query_set_omit_excluded
cli: move count to the new --exclude=(true|false|flag) naming scheme.
cli: move search to the new --exclude= naming scheme.
cli: move show to the new --exclude= option naming scheme.
test: add some exclude tests
emacs: make show set --exclude=false
emacs/notmuch-show.el | 6 +-
lib/notmuch.h | 23 ++-
lib/query.cc | 10 +-
man/man1/notmuch-count.1 | 5 +-
man/man1/notmuch-search.1 | 12 +-
man/man1/notmuch-show.1 | 16 ++-
notmuch-client.h | 1 +
notmuch-count.c | 17 ++-
notmuch-search.c | 32 +++-
notmuch-show.c | 50 ++++--
test/count | 21 ---
test/excludes | 423 +++++++++++++++++++++++++++++++++++++++++++++
test/notmuch-test | 1 +
test/search | 48 -----
14 files changed, 544 insertions(+), 121 deletions(-)
create mode 100755 test/excludes
--
1.7.9.1
More information about the notmuch
mailing list