Preventing the user shooting themself in the foot

Pieter Praet pieter at praet.org
Fri Jul 1 10:11:06 PDT 2011


On Fri, 01 Jul 2011 09:26:48 +1200, Michael Hudson-Doyle <michael.hudson at canonical.com> wrote:
> On Wed, 29 Jun 2011 22:40:07 -0700, Carl Worth <cworth at cworth.org> wrote:
> Non-text part: multipart/mixed
> Non-text part: multipart/signed
> 
> not sure why notmuch reply is putting that there :)
> 
> > The lack of a "move to next thread" binding helps encourage me to form
> > good habits. The goal I have when processing my inbox is to get
> > everything *out* of my inbox. I can do that by deciding one of several
> > common things:
> > 
> >     * I have nothing to do
> > 
> > 	In this case I should just archive the message immediately
> > 
> >     * I can deal with this message "on the spot" (such as a quick reply)
> > 
> > 	In this case, I should deal with the message, then archive it
> > 
> >     * I can't deal with this now, but need to later
> > 
> > 	This is the key scenario. The wrong thing to do is to leave the
> > 	message in my inbox, (that just makes things pile up and makes
> > 	my future inbox processing slow, demotivating, and
> > 	unreliable). The right thing to do is to tag this message in a
> > 	way that I'm sure I'll find it again when I will be equipped to
> > 	deal with it. And then I can archive the message.
> 
> I'm come to strongly agree that this is the Right Way to process email
> too, so should there be a keybinding for this last operation?  It should
> tag the message (or the thread?) with, say, 'task', and then proceeded
> as 'a' does.  'task' should be in the default searches you get in
> the notmuch hello buffer.

#+BEGIN_SRC emacs-lisp
  (define-key notmuch-show-mode-map "t"
    (lambda()
      "Flag and archive currently selected message, and move to the next.
If this is the last message, move to the next thread."
      (interactive)
      (notmuch-show-add-tag "flagged")
      (notmuch-show-advance-and-archive)))
#+END_SRC

Note that I use the "flagged" tag, since this corresponds to a maildir
flag, and can be synced via IMAP.

> I realize there is endless bikeshedding to be done on tag names and so
> on and also on allowing people to choose their own workflow, but I also
> think that this shouldn't stop the addition of a sensible default :)
> 
> Cheers,
> mwh
> _______________________________________________
> notmuch mailing list
> notmuch at notmuchmail.org
> http://notmuchmail.org/mailman/listinfo/notmuch

Peace

-- 
Pieter


More information about the notmuch mailing list